summaryrefslogtreecommitdiffstats
path: root/home-manager/zsh.nix
diff options
context:
space:
mode:
authorAndrey01892024-04-17 05:52:14 +0500
committerAndrey01892024-04-17 05:52:14 +0500
commitb51f9bc1014ce350abe73f2c419e0bf6512194c2 (patch)
tree404799cc86717de0a7115bbcec32ce0d8851241b /home-manager/zsh.nix
downloadold-b51f9bc1014ce350abe73f2c419e0bf6512194c2.tar.gz
old-b51f9bc1014ce350abe73f2c419e0bf6512194c2.tar.bz2
old-b51f9bc1014ce350abe73f2c419e0bf6512194c2.zip
Initial commit
Diffstat (limited to 'home-manager/zsh.nix')
-rw-r--r--home-manager/zsh.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/home-manager/zsh.nix b/home-manager/zsh.nix
new file mode 100644
index 0000000..7ce1349
--- /dev/null
+++ b/home-manager/zsh.nix
@@ -0,0 +1,37 @@
+{ config, ... }: {
+ programs.zsh = {
+ enable = true;
+ enableCompletion = true;
+ # enableAutosuggestions = true;
+ autosuggestion.enable = true;
+ syntaxHighlighting.enable = true;
+
+ shellAliases =
+ let
+ flakeDir = "~/nix";
+ in {
+ rb = "sudo nixos-rebuild switch --flake ${flakeDir}";
+ upd = "nix flake update ${flakeDir}";
+ upg = "sudo nixos-rebuild switch --upgrade --flake ${flakeDir}";
+
+ hms = "home-manager switch --flake ${flakeDir}";
+
+ conf = "nvim ${flakeDir}/nixos/configuration.nix";
+ pkgs = "nvim ${flakeDir}/nixos/packages.nix";
+
+ ll = "ls -l";
+ v = "nvim";
+ se = "sudoedit";
+ ff = "fastfetch";
+ };
+
+ history.size = 10000;
+ history.path = "${config.xdg.dataHome}/zsh/history";
+
+ oh-my-zsh = {
+ enable = true;
+ plugins = [ "git" "sudo" ];
+ theme = "agnoster"; # blinks is also really nice
+ };
+ };
+}