summaryrefslogtreecommitdiffstats
path: root/nixos/modules/sound.nix
diff options
context:
space:
mode:
authorAndrey01892024-04-17 05:52:14 +0500
committerAndrey01892024-04-17 05:52:14 +0500
commitb51f9bc1014ce350abe73f2c419e0bf6512194c2 (patch)
tree404799cc86717de0a7115bbcec32ce0d8851241b /nixos/modules/sound.nix
downloadold-b51f9bc1014ce350abe73f2c419e0bf6512194c2.tar.gz
old-b51f9bc1014ce350abe73f2c419e0bf6512194c2.tar.bz2
old-b51f9bc1014ce350abe73f2c419e0bf6512194c2.zip
Initial commit
Diffstat (limited to 'nixos/modules/sound.nix')
-rw-r--r--nixos/modules/sound.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/nixos/modules/sound.nix b/nixos/modules/sound.nix
new file mode 100644
index 0000000..21a7a28
--- /dev/null
+++ b/nixos/modules/sound.nix
@@ -0,0 +1,18 @@
+{
+ hardware.pulseaudio.enable = false;
+ sound.enable = true;
+
+ # rtkit is optional but recommended
+ security.rtkit.enable = true;
+
+ services.pipewire = {
+ enable = true;
+
+ alsa.enable = true;
+ alsa.support32Bit = true;
+ pulse.enable = true;
+
+ # If you want to use JACK applications, uncomment this
+ #jack.enable = true;
+ };
+}