summaryrefslogtreecommitdiffstats
path: root/nixos/modules/user.nix
diff options
context:
space:
mode:
authorAndrey01892024-04-17 05:52:14 +0500
committerAndrey01892024-04-17 05:52:14 +0500
commitb51f9bc1014ce350abe73f2c419e0bf6512194c2 (patch)
tree404799cc86717de0a7115bbcec32ce0d8851241b /nixos/modules/user.nix
downloadold-b51f9bc1014ce350abe73f2c419e0bf6512194c2.tar.gz
old-b51f9bc1014ce350abe73f2c419e0bf6512194c2.tar.bz2
old-b51f9bc1014ce350abe73f2c419e0bf6512194c2.zip
Initial commit
Diffstat (limited to 'nixos/modules/user.nix')
-rw-r--r--nixos/modules/user.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/nixos/modules/user.nix b/nixos/modules/user.nix
new file mode 100644
index 0000000..ea59b78
--- /dev/null
+++ b/nixos/modules/user.nix
@@ -0,0 +1,17 @@
+{ pkgs, ... }: {
+ programs.zsh.enable = true;
+
+ users = {
+ defaultUserShell = pkgs.zsh;
+
+ users.amper = {
+ isNormalUser = true;
+ description = "Ampersand";
+ extraGroups = [ "networkmanager" "wheel" "input" "libvirtd" ];
+ packages = with pkgs; [];
+ };
+ };
+
+ # Enable automatic login for the user.
+ services.getty.autologinUser = "amper";
+}