summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..70c1df0
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,46 @@
+{
+ description = "My system configuration";
+
+ inputs = {
+
+ nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
+ nixpkgs-stable.url = "github:nixos/nixpkgs/nixos-23.11";
+
+ home-manager = {
+ url = "github:nix-community/home-manager";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
+
+ nixvim = {
+ url = "github:nix-community/nixvim";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
+ };
+
+ outputs = { self, nixpkgs, nixpkgs-stable, home-manager, ... }@inputs:
+
+ let
+ system = "x86_64-linux";
+ in {
+
+ # nixos - system hostname
+ nixosConfigurations.nixos = nixpkgs.lib.nixosSystem {
+ specialArgs = {
+ pkgs-stable = import nixpkgs-stable {
+ inherit system;
+ config.allowUnfree = true;
+ };
+ inherit inputs system;
+ };
+ modules = [
+ ./nixos/configuration.nix
+ inputs.nixvim.nixosModules.nixvim
+ ];
+ };
+
+ homeConfigurations.amper = home-manager.lib.homeManagerConfiguration {
+ pkgs = nixpkgs.legacyPackages.${system};
+ modules = [ ./home-manager/home.nix ];
+ };
+ };
+}