summaryrefslogtreecommitdiffstats
path: root/nixos/modules/nixvim/nixvim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/nixvim/nixvim.nix')
-rw-r--r--nixos/modules/nixvim/nixvim.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/nixos/modules/nixvim/nixvim.nix b/nixos/modules/nixvim/nixvim.nix
new file mode 100644
index 0000000..df97be1
--- /dev/null
+++ b/nixos/modules/nixvim/nixvim.nix
@@ -0,0 +1,16 @@
+{
+
+ imports = [
+ ./opts.nix
+ ./keymaps.nix
+ ./autocmds.nix
+ ./plugins/plugins-bundle.nix
+ ];
+
+ programs.nixvim = {
+ enable = true;
+
+ defaultEditor = true;
+ colorschemes.oxocarbon.enable = true;
+ };
+}