summaryrefslogtreecommitdiffstats
path: root/nixos/modules/sound.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/sound.nix')
-rw-r--r--nixos/modules/sound.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/nixos/modules/sound.nix b/nixos/modules/sound.nix
new file mode 100644
index 0000000..21a7a28
--- /dev/null
+++ b/nixos/modules/sound.nix
@@ -0,0 +1,18 @@
+{
+ hardware.pulseaudio.enable = false;
+ sound.enable = true;
+
+ # rtkit is optional but recommended
+ security.rtkit.enable = true;
+
+ services.pipewire = {
+ enable = true;
+
+ alsa.enable = true;
+ alsa.support32Bit = true;
+ pulse.enable = true;
+
+ # If you want to use JACK applications, uncomment this
+ #jack.enable = true;
+ };
+}