summaryrefslogtreecommitdiffstats
path: root/nixos/modules/user.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/user.nix')
-rw-r--r--nixos/modules/user.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/nixos/modules/user.nix b/nixos/modules/user.nix
new file mode 100644
index 0000000..ea59b78
--- /dev/null
+++ b/nixos/modules/user.nix
@@ -0,0 +1,17 @@
+{ pkgs, ... }: {
+ programs.zsh.enable = true;
+
+ users = {
+ defaultUserShell = pkgs.zsh;
+
+ users.amper = {
+ isNormalUser = true;
+ description = "Ampersand";
+ extraGroups = [ "networkmanager" "wheel" "input" "libvirtd" ];
+ packages = with pkgs; [];
+ };
+ };
+
+ # Enable automatic login for the user.
+ services.getty.autologinUser = "amper";
+}