summaryrefslogtreecommitdiffstats
path: root/nixos/packages.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/packages.nix')
-rw-r--r--nixos/packages.nix116
1 files changed, 116 insertions, 0 deletions
diff --git a/nixos/packages.nix b/nixos/packages.nix
new file mode 100644
index 0000000..47ad8d5
--- /dev/null
+++ b/nixos/packages.nix
@@ -0,0 +1,116 @@
+{ pkgs, ... }: {
+ nixpkgs.config = {
+ allowUnfree = true;
+ permittedInsecurePackages = ["python-2.7.18.8" "electron-25.9.0"];
+ };
+
+ environment.systemPackages = with pkgs; [
+ # Desktop apps
+ chromium
+ telegram-desktop
+ alacritty
+ obs-studio
+ rofi
+ wofi
+ mpv
+ kdenlive
+ discord
+ gparted
+ obsidian
+ zoom-us
+ pcmanfm-qt
+
+ # Coding stuff
+ gnumake
+ gcc
+ nodejs
+ python
+ (python3.withPackages (ps: with ps; [ requests ]))
+
+ # CLI utils
+ neofetch
+ file
+ tree
+ wget
+ git
+ fastfetch
+ htop
+ nix-index
+ unzip
+ scrot
+ ffmpeg
+ light
+ lux
+ mediainfo
+ ranger
+ zram-generator
+ cava
+ zip
+ ntfs3g
+ yt-dlp
+ brightnessctl
+ swww
+ openssl
+
+ # GUI utils
+ feh
+ imv
+ dmenu
+ screenkey
+ mako
+ gromit-mpx
+
+ # Xorg stuff
+ #xterm
+ #xclip
+ #xorg.xbacklight
+
+ # Wayland stuff
+ xwayland
+ wl-clipboard
+ cliphist
+
+ # WMs and stuff
+ herbstluftwm
+ hyprland
+ seatd
+ xdg-desktop-portal-hyprland
+ polybar
+ waybar
+
+ # Sound
+ pipewire
+ pulseaudio
+ pamixer
+
+ # GPU stuff
+ amdvlk
+ rocm-opencl-icd
+ glaxnimate
+
+ # Screenshotting
+ grim
+ grimblast
+ slurp
+ flameshot
+ swappy
+
+ # Other
+ home-manager
+ spice-vdagent
+ libsForQt5.qtstyleplugin-kvantum
+ libsForQt5.qt5ct
+ papirus-nord
+ ];
+
+ fonts.packages = with pkgs; [
+ jetbrains-mono
+ noto-fonts
+ noto-fonts-emoji
+ twemoji-color-font
+ font-awesome
+ powerline-fonts
+ powerline-symbols
+ (nerdfonts.override { fonts = [ "NerdFontsSymbolsOnly" ]; })
+ ];
+}